Canadian Conference Numbers
Incident Report for UberConference
Resolved
This appears to be resolved.
Posted over 2 years ago. Jan 26, 2017 - 13:04 PST
Investigating
Investigating reports of busy signals on some of our Canadian conference numbers. Will update as we get more details.
Posted over 2 years ago. Jan 26, 2017 - 11:18 PST