Contacting Support via Chat is Currently Unavailable
Incident Report for UberConference
Resolved
This incident has been resolved.
Posted Apr 23, 2020 - 07:18 PDT
Identified
Currently, the option to reach out to support via chat is unavailable. We're working with our partner to bring resolution, we apologize for the inconvenience.
Posted Apr 23, 2020 - 07:10 PDT