Intermittent Issues in Amarillo, TX and Rochester, MN
Incident Report for UberConference
Resolved
Carrier has reported all clear.
Posted over 3 years ago. Mar 23, 2016 - 22:43 PDT
Identified
We have been advised by our carrier that this issue is weather/power related and we continue to see impact to services. Our carrier is still working to resolve this incident.

The following Markets are impacted:

546 - Amarillo, TX
620 - Rochester, MN
Posted over 3 years ago. Mar 23, 2016 - 16:47 PDT