Support unavailable through email and chat
Incident Report for UberConference
Resolved
This incident has been resolved.
Posted over 3 years ago. Jan 30, 2016 - 17:00 PST
Update
Ticketing system is working but ticket delivery is delayed so responses may be slow. Please use the phone number for urgent support
Posted over 3 years ago. Jan 28, 2016 - 16:18 PST
Investigating
Our support ticketing system is currently unavailable and we're unable to reply to email and chat support requests. Please use phone to contact us: (888) 793-1779
Posted over 3 years ago. Jan 28, 2016 - 10:52 PST