Investigating issue with conferencing
Incident Report for UberConference
Resolved
This incident has been resolved.
Posted Dec 12, 2019 - 14:02 PST
Investigating
Investigating issue with conferencing -- update to follow.
Posted Dec 12, 2019 - 11:45 PST