International Access Numbers not connecting
Incident Report for UberConference
Resolved
This incident has been resolved.
Posted Sep 19, 2019 - 18:44 PDT
Identified
At the moment Uberconference's international access number are experiencing connectivity issues. Our team is working to bring resolution. Thank you for your patience.
Posted Sep 19, 2019 - 15:35 PDT