Screen Sharing experiencing problems
Incident Report for UberConference
Resolved
Screen Sharing issue has now been resolved. We'll provide insight as to what happened once we gather all the details. Thank you for your patience and our apologies for the inconvenience this caused.
Posted over 1 year ago. Jan 31, 2018 - 10:29 PST
Investigating
Screen Share appears to be unresponsive, our team is investigating. Thank you for your patience.
Posted over 1 year ago. Jan 31, 2018 - 09:58 PST